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Preface

Welcome to the ReadMeF User Guide.

This preface contains the following information:

· Purpose
· Audience
· ReadMeF Documentation Set
· How this Guide is Organized
Purpose

This document provides a guide to the ReadMeF application.
Audience

This guide is intended for IRS users, who need to view returns from the xml data.
ReadMeF Documentation Set

The ReadMeF user documentation includes the manuals described below.

Table 1: ReadMeF User Documentation Set

	Manual
	Description

	ReadMeF User Guide (this document)
	Explains how to use the ReadMeF application and the various tasks it can perform.

	ReadMeF Installation Guide
	Explains how to install the ReadMeF application (for users external to IRS).


How this Guide is organized
This document contains the sections described below.

Table 2: Contents of this Guide

	Section
	Description

	Chapters 1 – 14
	Describe the main functions of the application.

	Chapter 15 - User Interface Quick Reference
	Provides a brief description of the application functions organized by menu item.

	Chapter 16 – Customizations for Entity Name in Tree
	Describes requested form-specific customizations that have been applied


Chapter 2:  About ReadMeF
ReadMeF was designed to assist agents in reviewing electronically filed corporate and partnership returns. ReadMeF can display virtually all of an electronically filed return in a user friendly manner. A tax return is displayed as a tree listing all the entities, forms and schedules included in the return. When a tree node representing an entity is selected, the contents of the entity are displayed on the right. The tree view facilitates efficient navigation of the tax return.
Although ReadMeF displays the majority of the forms contained in a tax return, it does not display certain kinds of attachments known as binary attachments. Such binary attachments are filed as Adobe Acrobat PDF files and are part of the LMSB Imaging Network (LIN) PDF files. 

ReadMeF does not allow book marking that can be done in Adobe Acrobat. If book marking is required, an agent can utilize ReadMeF as a pre examination tool and then use Adobe Acrobat to book mark the LIN PDF file for future reference. 

Chapter 3:  Setting up Internet Explorer

Open Internet explorer. From the Tools menu select Internet Options. This will bring up the following window.
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Select the Advanced tab at the top right hand side. This will show the following window.
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Make sure the Disable script debugging (Other) is unchecked as shown above. Click OK to close the window with this change saved.
Chapter 4:  Downloading Returns

ReadMeF transforms XML files into viewable tax returns. ReadMeF cannot be used to view PDF returns obtained from the LIN system. 

These five steps are required to view returns using ReadMeF:
1. Download a file from LIN to your computer. 

2. Extract the xml file to D:\Program Files\ReadMef\ReadMefData or an encrypted        subdirectory of your choice. 

3. Open ReadMeF. 

4. Open the xml file in ReadMef.
5. Download the LIN PDF document to review any documents or “Binary Attachments” that are filed with the return, but are not part of the xml file. 

Note: You must either encrypt this folder on your computer, or remove the return data when done, or move the return data to an encrypted folder.
These steps are explained in greater detail in the pages that follow. 

Downloading XML file: 
The first step in downloading an XML file is to start with the e-mail you received from the LIN system (figure 1). 

[image: image4.emf]
(Figure1) 

To start the process, double left click on the link provided in the e-mail (figure 2). 

[image: image5.emf]
(Figure 2) 

The link will take you to a web site that displays the information about the document, such as form type, number of pages, and size of the file (figure 3). 
[image: image6.emf]
(Figure 3) 

As noted earlier, ReadMeF does not allow you to view tax returns in PDF format. The majority of returns available through the LIN system are also available in XML format (figure 4). If you do not find an XML section please refer to the section titled “What to do if no XML link is available”.  

[image: image7.emf]
(Figure 4)

To download the XML file right click on its link and then select the “Save Target As…” option as shown (figure 5). 

[image: image8.emf]
(Figure 5) 

The File Download and Save As dialog boxes will appear (figure 6). The name of the zip file will pre-populate the File Name box. 

[image: image9.emf]
(Figure 6) 
Click the drop down arrow next to Save In box and navigate to the d:\program files\readmef\readmefdata folder or an encrypted subdirectory of your choice. (figure 7)
[image: image10.emf]
(Figure 7) 

We recommend that you rename the file in order to allow you to organize the returns. This will allow you to quickly locate your files when using ReadMeF. You can give the file a name by overwriting the name in the File name box (figure 8). 

[image: image11.emf]
(Figure 8) 

To begin downloading the XML to your computer simply left click the Save button (figure 9). 

[image: image12.emf]
(Figure 9) 
The file will download to your selected location and the download complete box will appear (figure 10). Left click Close to exit the window. 
[image: image13.emf]
(Figure 10) 
Unzipping XML file: 
Now that you have downloaded the XML file to your computer you will need to extract or unzip the file before you can use it. Follow the instructions listed on the following page(s) to accomplish this. 

Open up My Computer or Explorer and navigate to the location where you saved the zip file. You will see that your zip file appears in the folder. You should also note that the file has been automatically encrypted for you as well.
The next step is to double click the compressed file and follow the instructions to extract the files to the location you choose.
After extraction is complete you will see your folder appear (figure 13). Note that the folder name is based upon the name you gave to the zip file upon downloading. [image: image14.emf]
(Figure 13) 

Opening the folder you will see the xml file appear (figure 14). You are now ready to begin using ReadMeF. You can repeat these steps to add additional tax returns to ReadMeF as needed. The original zip file may be deleted if desired. 

[image: image15.emf]
(Figure 14) 

What if there is no XML link: 
Most electronically filed returns contain XML files. However, if the email you received for the LIN system does not contain a link to the XML file, you can forward the email with the link to *LMSB PSP LIN@irs.gov . If a return was electronically filed, request the XML file even if the LIN system states the XML file is not available.
Chapter 5:  Opening ReadMeF

To open the application:

1. Choose C (C:\Program Files\IBM\ReadMef) or D drive depending on where ReadMef is installed and run the application by double clicking on the executable shown below (figure 15). The figure shows a sample application path and location.
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 (Figure 15)
This will bring up the main ReadMef application window (figure 16).
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(Figure 16) 
Chapter 6:  Opening a return in ReadMeF

To open an XML file, go to the menus at the upper left corner and select File->Open (figure 17). 
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(Figure 17) 

You can also open files using this icon on the toolbar -
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The Open dialog box appears (figure 18). Navigate to the XML file of interest by using the drop down arrow and selecting sub folders if needed. 

[image: image20.emf]
(Figure 18) 
Select the XML file by left clicking it once (figure 19).
 [image: image21.emf]
(Figure 19) 

Left click Open 

[image: image22.emf]
Chapter 7:  Using the Tree

Once opened, your XML file should be transformed and displayed in the left pane. (figure 20). 

[image: image23.png]



(Figure 20) 
The view shown in figure 20 is commonly referred to as “the tree”. The tree view is similar to the view you see in windows explorer. A tree node with a ‘+’ sign next to it has additional forms listed within it. To see the list, left click the ‘+’ sign. The ‘+’ sign changes to ‘–‘ to indicate that the node is in expanded state. Left click the ‘–‘ sign to collapse the node.
To see the main return data, expand the ReturnData link. All attached forms should be listed below (figure 21). 
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(Figure 21)
Chapter 8:  Viewing forms/attachments

To view a form or attachment listed in the tree, left click on it. The form will be loaded into the Form Display area on the right (figure 22). 
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(Figure 22)
Note that the divider between the Tree area and the Form Display area can be moved to increase or decrease either area. 
The display on the right is a transformed view of the form xml. The form xml is transformed via a stylesheet to generate the displayed format. If the stylesheet pertaining to the form type and tax year is not found on the system for any reason, or if there are any transformation errors, the form xml is formatted via a generic predefined template and then displayed. For instance, the generic version of the above (Figure 22) display is shown in Figure 22a below.
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(Figure 22a)

Chapter 9:  Using the Push-Pin Feature

Many lines on the tax return require the taxpayer to attach forms (such as form 1125-A shown below) that breakdown the amount specified as the line value. In ReadMeF, such attachments are accessible via a link called a push pin (figure 23). 
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(Figure 23)
The attached schedule can be accessed by left clicking the push pin. The schedule will be loaded into the Form Display area (figure 24).
Any attachment at the line level can be accessed by clicking on the pushpin next to the line as shown in Figure 23.
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(Figure 24)

Multiple Attachment push pins: 
The pushpin on the upper left corner of a form (Figure 25) provides access to all attachments made at the form level as opposed to an attachment that is made at the line level.
You can use the push pin at the upper left corner of the form to quickly display a list of all its attachments at the form level. As shown below (figure 25), there is a push pin located at the upper left corner of Form 1120. 

[image: image29.emf]
(Figure 25) 
Left clicking the push pin will produce a list of attachments as shown below (figure 26). Placing the cursor on a listed form / attachment will highlight it.
[image: image30.emf]
(Figure 26) 

Left clicking on a form / attachment will result in its being loaded into the Form Display area (figure 27). 

[image: image31.emf]
(Figure 27) 

Using the navigation buttons: 
The following navigation features are provided:

· The left and right arrow navigation buttons work like the browser back and forward navigation buttons:
For instance, after using a push pin to view an attachment you can use the back button to return to the form which had the push pin. The back button is shown below (figure 28). 

[image: image32.png]



(Figure 28) 

Conversely, once you have returned to the previous form, you can navigate forward again to where you were, by clicking the forward button (figure 29). 

[image: image33.png]



(Figure 29) 

· After traversing through multiple push pins, clicking on the double-arrow button will take you back to the original parent form where the traversing started. 

[image: image34.png]



(Figure 30) 

· To go directly to any form / attachment, click on its listing in the tree. 
Chapter 10:  Using the Search Feature

ReadMeF has a search feature that allows you to search the entries in the tree. ReadMeF does not allow you to search the content of the forms or attachments. To use the search feature in the tree, left click on the search button located on the toolbar (figure 31) or use menu Edit->Search. 

[image: image35.png]


 (Figure 31) 

The search dialog box will appear (figure 32). You can enter the key word(s) that you want to search for.
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 (Figure 32) 

Set the ‘Ignore Case’ and ‘Start at the top’ options. When a search is initiated, it will automatically start at the top.  After finding the first match, ‘Start at the top’ will be automatically unchecked so that subsequent matches can be found by clicking on ‘Find Next’. Left clicking ‘Find Next’ will take you to the first match as shown below (figure 32a). 
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(Figure 32a)
If you wish to search for the next occurrence, click on ‘Find Next’ again. Even if the search window is closed, you can use the Find Next keyboard shortcut, F3 to find the next match.
Chapter 11:  Binary Attachments

Binary Attachments are non-xml attachments filed by the taxpayer. The most commonly encountered attachments are third party documents (Articles of Incorporation), documents requiring signatures (Appraiser documentation), and hand written or typed schedules prepared by the taxpayer and attached to the official return. Such binary attachments are listed in the tree as shown below (figure 33). 

[image: image38.emf]
(Figure 33) 

ReadMeF can’t be used to view the content of a binary attachment. However, if you select a binary attachment, ReadMef will display any information available pertaining to the binary attachment (such as Attachment Location) as shown below (figure 34). 

[image: image39.emf]
(Figure 34) 

Using this information, you can locate the attachment in the PDF LIN return. To view the actual attachment, you will need to open the PDF return. 

Hint: The binary attachments will appear at the very end of the PDF files. 

Chapter 12:  Printing in ReadMeF
ReadMeF allows you to print selected forms and attachments. ReadMeF was not designed to print the entire return. If you want to print the return in its entirety please use the PDF file obtained from the LIN system. 
Internet Explorer Page setup: 
Before you print any documents in ReadMeF you must first adjust the margins in Internet Explorer page setup. Once you perform this one time change your documents will print correctly. 

The instructions below will outline how to perform this task. 

Open up your Internet Explorer and then click on File/Page Setup (figure 34) 

[image: image40.emf]
(Figure 35) 

By default the Internet Explorer page setup defaults to set the margins to 0.75 for all sections. These settings result in your forms being cut off at the margins when printing (figure 36). 

[image: image41.emf]
(Figure 36) 

Please change the margins to 0.25 for the left, right, top, and bottom margins and then click the OK button to apply the changes needed to ReadMeF to correctly print. 

Using Print and Print Selected:

The File->Print (Current Display) menu item will print the current display in the Form Display area. The Print icon in the toolbar menu does the same thing. 
To print a single page from a multipage form you can use the File->Print Preview menu item. See the Print Preview section for more details.

The File->Print Selected menu item (figure 37a) allows multiple forms to be printed at one time. The forms selected must either be all Portrait documents or all Landscape documents. If any forms selected do not have the correct orientation, a message box will guide you to make the correct selections. 
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(Figure 37a)
As shown below (figure 37b), you have the option to either print up to 10 documents together (Print Combined Up To 10) as one printing job or print each document individually (Print Individually) as a separate printing job. The Print Combined option is especially useful if you want to print up to 10 documents to one file. If more than 10 documents are selected, the first 10 documents will be included in the combined print job. The Printing Preferences dialog box will let you choose the printer.
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(Figure 37b)

Printing can be cancelled by clicking on the Cancel Print button. As each document is being printed, a status message will be displayed in the print window. If you wish to cancel printing at any time, you must click on the Cancel Print button. Any documents that have already commenced printing as informed in the status message will still be printed.
Printing in landscape mode: 
Certain forms or attachments, such as form 1118, do not print correctly in normal print mode. These documents were designed to be printed in landscape mode. ReadMeF allows you to highlight the forms which were designed to be printed in this manner. To see these documents, use menu item Edit->Highlight Landscape Documents. This will highlight all landscape documents in yellow as shown below (figure 38). 
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(Figure 38) 

To set printing in Landscape select the Preferences button in the Print dialog box (figure 39), then select Landscape in Printing Preferences (figure 40).
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(Figure 39) 
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(Figure 40)

Using the print preview: 
You can use the print preview to choose additional options when printing a document in ReadMeF. Print preview also allows you to view the print format of the document prior to printing. This allows you to ensure that your form will print as you intended. 

To use print preview File->PrintPreview (Current Display) (figure 41). 
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(Figure 41)
The form will be displayed in a Print Preview window as shown below (figure 42). If the document is more than a page long you can view it using the scroll bars. 

[image: image48.emf]
(Figure 42) 

Using the links on the print preview toolbar (figure 43) you can change the way that your document displays or prints. 

[image: image49.emf]
(Figure 43) 
These buttons and their functions are described below:   

[image: image50.emf]  Brings up the Print dialog box, use this box to choose your printer as well as the page(s).
[image: image51.emf]  Page Setup brings up the page setup dialog box (figure 44). This box allows you to make changes to the margins if desired. It also allows you to choose the paper orientation. Portrait prints from top to bottom, landscape flips the document to print sideways. 
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(Figure 44) 

[image: image53.emf]  The Printer button inside the page setup box brings up the printer selector dialog box (figure 45). 
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(Figure 45)
Use the drop down arrow to choose which printer you want to print your document to. After making your selection, click OK to print. 

 [image: image55.emf]  These arrows allow you to choose which page of the documents you want to view. The left arrows take you to the first page or back one page. The right arrows take you forward or to the last page. You can go directly to a specific page by typing the page number in the white box. 

[image: image56.emf]  These buttons allow you to zoom out, zoom in, or specify how large you want to view the document(s). Use the drop down arrow to choose a preset value or type in a ratio in the white box. 

[image: image57.emf]  Close will allow you to close the preview window and return to ReadMeF. 

Chapter 13:  Using the Pen Function
Taxpayers sometimes make notes or write-in information on forms that is normally not displayed during the capture of the data. If there are any such items, you will find a pen icon on the form. An example is shown below (figure 50). 

[image: image58.emf]
(Figure 50) 

To view the information, left click the pen link and the information will be displayed in the Form Display area. (figure 51)
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(Figure 51)

Chapter 14:  Using Filters

[image: image1.wmf]Filters can be applied when viewing the generic view of a document and when using the export function. Filtering is performed on the xml tag name and it is important to note that filters are case sensitive. Filtering a document enables one to display only fields that have an xml tag name containing one of the filters. For instance, if the xml tag name of a field contains ‘Refund’ or ‘EIN’ (Figure 52), it will be displayed. Choose Filter->Setup Filter menu item to bring up the dialog box shown below (Figure 52).
  (Figure 52)
To add a new filter, type the name in the Tag Name textbox and click the Add button. Alternatively it may be easier to go to the XML View of the document and copy the element name that you want to filter on, and then paste it in the Tag Name textbox. Information on how to go to the XML View is shown in the Quick Reference guide.
To delete an existing filter, right click that filter and click delete.
Note: After making all the changes click OK to save the changes and close the dialog box.

It is worth noting that when filtering takes place all filters are applied, therefore the fewer the filters, the faster the process. Figures 53 and 54 show how the filters are used.
A single form may be filtered using the Filter->Filter Current Document menu item.
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(Figure 53)
Note that if a higher level node is selected, such as the Return Data node, then all forms below that node will display their filtered data when using the Filter Selected Node command. Similarly, selecting and filtering the top Return node in a multi return node will display filtered data for all the returns.
Filters can be applied to all exported data using the File->Export Selected Documents As->Filtered CSV menu item (figure 54). 
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(Figure 54)
Chapter 15:  Exporting Data

Data can be exported using the File->Export Selected Documents As->CSV menu item. When used, all data from selected nodes will be exported to a csv file. The application prompts the user for a file name and a location where it will be saved.
Using the File->Export Selected Documents As->Filtered CSV menu item, filtered data can be exported to a file.

It is also possible to export from the Form Display window by right-clicking the form and selecting the Export to Microsoft Excel option, although this is not recommended. A more reliable method is to select the region on the form you want to export, copy it to the clipboard, and paste it into an excel spreadsheet.

Chapter 16:  User Interface Quick Reference
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Top Navigation Bar (Toolbar) Items
	Navigation Button
	Function

	[image: image63.png]



	Opens a return data xml file.
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	Prints the current form in display, all pages for multi-page forms.
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	Search the Tree to find a particular form. Allows searching on partial names.
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	Goes to the previous page in the history stack and makes it the current display.
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	Goes to the next page in the history stack and makes it the current display.
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	Goes to the Parent Form. The user is taken back to the Parent Form after traversing through multiple push-pins. All pages in between are popped off the history stack.
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	Shows the generic view (table format with element names and values) for the current display.
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	Shows the xml for the current display.
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	Filters the current display to include only those fields whose xml tag name contains one of the user set filters.
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	Toggles between the following three options:
· Tree Panel has a width of 200 and Content Display Panel takes the rest.

· Tree Panel has a width of 500 and Content Display Panel takes the rest.

· Tree Panel disappears and Content Display Panel fills the entire view.
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	Transform Dynamic – The current display will have tables with scroll bars as necessary.
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	Transform In-line – The current display will have expanded tables so all rows can be viewed.
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	Transform Separated – The current display will have table data separately at the bottom.


File Menu 
[image: image76.png]Read Mef - D:\Projects\ReadMef\Data\D

Fle| Edt Options View Fier Help

Open o |
Close ame | T
Print (Curret Disley) cep  pra\C
Printreview (Curtent Display) Cr+W

int Seectad ,
Export Slected Documents A5 ,

Recent Fies ,

Ext [

TI20°Schedule T
[TIIRS 1120 Schedule M 3
[TIIRS 1120 Schedule N
RS 1120 Schedule O
RS 1120 Schedule PH
RS 1120 Schedule UTP




	File Menu Item
	Function

	Open
	Allows the user to navigate to the xml data file to be opened.

	Close
	Closes the current xml data file and clears all displays.

	Print (Current display)
	Prints the current display.

	Print Preview (Current display)
	Displays a print preview of the current display.

	Print Selected

► Portrait Documents

► Landscape Documents
	Prints forms that are selected (checked) in the tree. Prints either portrait or landscape documents. All documents selected must be of the same orientation.

	Export Selected Document As      

► Comma Separated Values (CSV) 

► Filtered CSV
	Exports the currently selected node in the tree to a CSV file. Data can be filtered too.

	Recent Files
	Displays a list of recently opened files with the most recently opened file at the top of the list. Up to 10 file locations will be retained.

	Exit
	Closes the application and deletes all temporary files.


Edit Menu 
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	Edit Menu Item
	Function

	Find
	Search the Tree to find a particular form. Allows searching on partial names.

	Find Next
	Searches the Tree for the next node that matches the search criteria.

	Select Landscape documents
	Selects all landscape documents in the Tree.

	Select Portrait documents
	Selects all portrait documents in the Tree.

	Select None
	De-Selects all documents in the Tree.

	Highlight Landscape documents
	Highlights all landscape documents in the Tree.

	Highlight None
	Un-highlights all documents in the Tree.


Options Menu 
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	Options Menu Item
	Function

	Zoom Current Transformed Document    

► 100%, 125%, 150%
	Zoom the transformed document in the current display to – 100% / 125% / 150%.

	Default Directories ► Data Directory
	Sets the default data directory where the application will prompt the user to open xml data files from.

	Remove Old Temp Files
	Deletes all temporary files in the working directory. Does not remove the custom settings file that has information that needs to be saved between application usages.   


View Menu 
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	View Menu Item
	Function

	XML Tree
	Switches between the following two options -

· Menu Item Unchecked - Tree Panel disappears and Content Display Panel fills the entire view.

· Menu Item Checked – Tree Panel appears with the width that it was last set to, either by using the Grid Splitter or the Toggle XML Tree View Button 




Filter Menu
[image: image80.png]B Read Mef - D:\Projects\ReadMef\Data\Data\1120 with multiple f
File Edt Options View |Filler] Help

Filter Current Document F12

DSBEE e cuteriz

= Transmission D: \Projects\ReaUMerData LT~
= [Return_Maple Finance Incorporated
eSurn_aple Fin:

Ay





	Filter Menu Item
	Function

	Filter Current Document
	Filters the current document and displays the filtered data. 

	Setup Filter
	Sets up elements for filtering. Note: Filtering is based on XML element names and is case sensitive. For reference, element names can be seen in the Xml View of a document.


Help Menu
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	Help Menu Item
	Function

	About
	Displays application information.


Menu Shortcut Commands
	Menu Item
	Shortcut Key

	File – Open
	Ctrl+O

	File – Close
	Ctrl+F4

	File – Print (Current Display)
	Ctrl+P

	File – PrintPreview (Current Display)
	Ctrl+W

	File – Print Selected – Portrait Documents
	Ctrl+D

	File – Print Selected – Landscape Documents
	Ctrl+L

	File – Export Selected Documents As - CSV
	F5

	File – Export Selected Documents As – Filtered CSV
	Ctrl+F5

	File – Exit
	Ctrl+F11

	Edit – Find
	Ctrl+F

	Edit – Find Next
	F3

	Select Landscape Documents
	Ctrl+U

	Select Portrait Documents
	Ctrl+Y

	Select None
	Ctrl+N

	Highlight Landscape Documents
	Ctrl+H

	Highlight None
	Ctrl+G

	Options – Current Transformed Document - Zoom 100%
	F6

	Options – Current Transformed Document - Zoom 125%
	F7

	Options – Current Transformed Document - Zoom 150%
	F8

	Options – Default Directories – Data Directory
	F2

	Options – Remove Old Temp Files
	Ctrl+R

	View – Xml Tree
	Ctrl+T

	Filter - Filter Current Document
	F12

	Filter – Setup Filter
	Ctrl+F12

	Help – About
	F1


Chapter 17:  Customizations for Entity Name in Tree
The Tree view of a return enables a user to scan the return for specific forms. There can be several instances of a form type in a return. Customizations were requested that certain form types display their “entity name” in the tree to enable easy identification of the form. The requested list of form types and associated entities customizations is listed below. Please note that the entity name might differ slightly depending on the tax year.
	Form Type
	Displayed Entity

	IRS 926
	TransferorName

	IRS 8858
	ForeignDisregardedEntityName

	IRS 8865
	ForeignPartnershipName

	IRS 8883
	TargetCorporationName

	IRS 5471
	ForeignCorporation

	IRS 5471 Schedule J
	ForeignCorporationName

	IRS 5471 Schedule M
	ForeignCorporationName

	IRS 5471 Schedule O
	ForeignCorporationName

	IRS 5472
	RelatedPartyName

	IRS 1065 Schedule K1
	PartnerName

	IRS 1065B Schedule K1
	PartnerName

	IRS 1120S Schedule K1
	ShareholderName

	IRS 8858 Schedule M
	ForeignDisregardedEntityName

	IRS 8865 Schedule K1
	PartnershipsName

	IRS 8308
	TransferorName


A form may have other forms and dependencies associated with it. User feedback indicated that it would help if for some form types, some of their dependencies can be tied back to the parent form by displaying the parent form’s entity name in the tree. For instance, IRS 5471 has several dependencies attached to it. Some dependencies are attached at the form level and others are attached to specific line items.  The user requested that some of these dependencies display the entity name of the IRS 5471 that they are attached to. The requested forms and their dependencies customizations are listed below. Please note that the entity name, line item name and dependency name might differ slightly depending on the tax year.
	Form Type and Entity Name
	Line Item Name
	Dependency Name

	IRS 5471 - ForeignCorporation
	CategoryOfFiler3Ind
	Category3FilerStatement

	IRS 5471 - ForeignCorporation
	ForeignOtherIncomeAmt
	OtherIncomeForm5471Statement

	IRS 5471 - ForeignCorporation
	USOtherIncomeAmt
	OtherIncomeForm5471Statement

	IRS 5471 - ForeignCorporation
	ForeignOtherDeductionsAmt
	ItemizedOtherDeductionSch2

	IRS 5471 - ForeignCorporation
	USOtherDeductionsAmt
	ItemizedOtherDeductionSch2

	IRS 5471 - ForeignCorporation
	BegngAcctPrdOtherCurrAssetsAmt
	ItemizedOtherCurrentAssetsSch

	IRS 5471 - ForeignCorporation
	EndAcctPrdOtherCurrAssetsAmt
	ItemizedOtherCurrentAssetsSch

	IRS 5471 - ForeignCorporation
	BegngAcctPrdInvstSubsidiaryAmt
	InvestmentInSubsidiariesStmt

	IRS 5471 - ForeignCorporation
	EndAcctPrdInvstSubsidiaryAmt
	InvestmentInSubsidiariesStmt

	IRS 5471 - ForeignCorporation
	BegngAcctPrdOthInvestmentsAmt
	ItemizedOtherInvestmentsSch

	IRS 5471 - ForeignCorporation
	EndAcctPrdOthInvestmentsAmt
	ItemizedOtherInvestmentsSch

	IRS 5471 - ForeignCorporation
	BegngAcctPrdOtherCurrLiabAmt
	ItemizedOthCurrLiabilitiesSch

	IRS 5471 - ForeignCorporation
	EndAcctPrdOtherCurrLiabAmt
	ItemizedOthCurrLiabilitiesSch

	IRS 5471 - ForeignCorporation
	BegngAcctPrdOthLiabilitiesAmt
	ItemizedOtherLiabilitiesSch

	IRS 5471 - ForeignCorporation
	EndAcctPrdOthLiabilitiesAmt
	ItemizedOtherLiabilitiesSch

	IRS 5471 - ForeignCorporation
	BegngAcctPrdPaidInOrSurplusAmt
	PaidInOrCapSurplusRecnclStmt

	IRS 5471 - ForeignCorporation
	EndAcctPrdPaidInOrSurplusAmt
	PaidInOrCapSurplusRecnclStmt

	IRS 5471 - ForeignCorporation
	BegngAcctPrdOtherAssetsAmt
	ItemizedOtherAssetsSchedule

	IRS 5471 - ForeignCorporation
	EndAcctPrdOtherAssetsAmt
	ItemizedOtherAssetsSchedule

	IRS 5471 - ForeignCorporation
	OtherAdjustmentsNetAddnAmt
	EarningsAndProfitsOtherAdjStmt

	IRS 8858 - ForeignDisregardedEntityName
	TotalNetAdditonsAmt
	EPTaxableIncomeAdjustmentSch

	IRS 8858 - ForeignDisregardedEntityName
	TotalNetSubtractionsAmt
	EPTaxableIncomeAdjustmentSch


 User feedback also indicated that some schedule types that are attached to certain types of line items across several form types be made more identifiable by displaying the entity name of the parent form that they are attached to. The requested customizations are listed in the table below. . Please note that the entity name, line item name and the schedule name might differ slightly depending on the tax year.

	Form Type and Entity Name
	Line Item Name
	Schedule Name

	IRS1065 Schedule K1 - PartnerName
	Form Level
	SchK11065MiscItemStmt

	IRS1065B Schedule K1 - PartnerName
	IRS1065BSchK1OtherDetail
	ScheduleK11065BMiscItemStmt

	IRS1065 Schedule K1 - PartnerName
	NetSection1231GainLossAmt
	NetSection1231GainLossStmt

	IRS 8865 Schedule K1- PartnershipsName
	NetSection1231GainLossAmt
	PssvActySect1231GainLossStmt

	IRS 1120S Schedule K1 - ShareholderName
	NetSection1231GainLossAmt
	PssvActySect1231GainLossStmt

	IRS 1120S Schedule K1 - ShareholderName
	NetSection1231GainLossAmt
	AtRiskActySect1231GainLossStmt

	IRS 1120S Schedule K1 - ShareholderName
	NetSection1231GainLossAmt
	ItemizedOtherIncomeLossSch
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