IRS Logo
Print - Click this link to Print this page

Minimum Computer Requirements

When using the Free File Fillable Forms program, we recommend you review all the information on this page.

IMPORTANT: 

  • Do not use Non-Recommended Browser or Operating System
  • Do Not use handheld mobile devices with this program

Your use of the above runs the risk of experiencing technical issues that you may not be able to resolve.

Even if the program appears to work using the above, the program may cease working with your browser, operating system or device at any time and you may not be able to recover your account or your tax information.

Recommended Operating Systems and Browsers

Operating Systems: Windows and Mac only

Browsers: The program will run best when you use one of these recommended browsers.

  • Google Chrome - Any version
  • Internet Explorer version 11 (Do not use Edge)
  • Mozilla Firefox version 26, (Do not use 43.0.1 43.0.2 or 43.0.3)

Browser settings:

  • Set the language to default 
  • Enable JavaScript and cookies
  • Turn off:
    • Pop-up blockers
    • Auto-fill features
    • Private browsing features

Optimize Your Experience

You can optimize your Free File Fillable Forms experience by meeting these minimum requirements and having a combination of these operating systems and browsers:

RAM: 512 MB
Monitor: 1024x768 or higher screen resolution
Internet Connection: High-speed connection
Other Software: Acrobat Reader 8.0+ (for printing)

Processor:

  • Windows: Pentium 4 3GHz or equivalent
  • Macintosh: PowerPC G5 2GHz or Intel-based processor

Operating Systems with Oldest Supported Browser (Actual version, not emulated)

  • Windows 8, 7, and Vista support:
    • Google Chrome 4.x
    • Mozilla Firefox 11.x
    • Microsoft Internet Explorer 10.x (on Windows 8)
  • Windows XP Service Pack 2 supports:
    • Google Chrome 4.x
    • Mozilla Firefox 11.x
  • Mac OS X 10.7 (Lion) supports:
    • Google Chrome 4.x
    • Mozilla Firefox 11.x
  • Mac OS X 10.6 (Snow Leopard) supports:
    • Google Chrome 4.x
    • Mozilla Firefox 11.x
  • Mac OS X 10.5 (Leopard) supports:
    • Google Chrome 4.x
    • *Mozilla Firefox 11.x

*Although older versions of Firefox may appear to function normally on OS X 10.4 and 10.5, we do not recommend using these browser/OS combinations due to potential security issues.

Page Last Reviewed or Updated: 09-Nov-2016